problemi con la creazione dell'immagine

L
Leo (300 points)
2 4 5
asked Dec 3, 2021 in HW6 by Leo (300 points)
Buonasera a tutti!

premetto che spero di essere chiaro con la domanda seguente...

ho un problema con il salvataggio delle mappe delle città, le quali dopo aver provato vari test e creato più zip del homework 6, si salvano con un output corretto(ossia vengono salvate le immagini identiche ai file.png già messi a disposizione. Il mio problema consiste nel capire come mai il mio codice disegna la mappa in modo identico agli esempi, ma i test li fallisce tutti perchè l'immagine non inizia a coordinate (0,0,0) ma ad altre, nonostante il salvataggio dell'immagine è identico al formato. Vi ringrazio in anticipo.
180 views

2 Answers

simonemignanelli (2130 points)
1 2 22
answered Dec 3, 2021 by simonemignanelli (2,130 points)
Guarda vorrei aiutarti ma così è impossibile, anche un solo pixel sbagliato può non farti passare i test tranquillamente. Se non inizia con cordinate (0,0,0) sicuro non è identico, ricontrolla bene il codice. Se aggiungi più dettagli di come hai implementato il codice forse possiamo darti una mano. Naturalmente controlla anche se ritorni i valori corretti di larghezza e altezza del file.
andrea.sterbini (172300 points)
510 927 1776
answered Dec 3, 2021 by andrea.sterbini (172,300 points)
controlla che i palazzi a E e W siano a distanza 'spaziatura' dai bordi sinistro e destro
e che il più alto della prima riga e dell'ultima siano a 'spaziatura' pixel dal bordo superiore ed inferiore

Nota che il messaggio di errore ti dice qual'è il primo pixel sbagliato e a che coordinate si trova.
Dovrebbe essere l'angolo in alto a sinistra del palazzo più alto della prima riga.
Da quello che vedo NON ci hai messo il rettangolo.
L
Leo (300 points)
2 4 5
commented Dec 3, 2021 by Leo (300 points)
Grazie mille per entrambe le risposte, provvederò a capire l'errore che ho effettuato