Prolema: 'utf-8' codec can't decode byte 0xf9

a
alessio taruffi (680 points)
3 12 15
asked Nov 29, 2021 in HW6 by alessio taruffi (680 points)
closed Nov 29, 2021 by alessio taruffi
Ottengo questo errore quando provo a fare i test

UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf9 in position 3696: invalid start byte

Ho provato a cancellare la consegna

Ho provato ad inserire # -*- coding: utf-8 -*

Ho eliminato program01 e ne ho creato un'altro a partire da un file di testo

Cosa posso fare? noto che il byte in errore (0xf9) è diverso da quello in altri errori posti in altre domande
207 views
closed with note: risolto

2 Answers

saidai (1340 points)
1 2 13
answered Nov 29, 2021 by saidai (1,340 points)
Hai provato col file in inglese? Hai provato a cancellare anche tutti i commenti?
a
alessio taruffi (680 points)
3 12 15
commented Nov 29, 2021 by alessio taruffi (680 points)
Tutti i commenti si, il file in inglese in che senso? ricopiare tutto la dentro e salvare quello come program01 ?
saidai (1340 points)
1 2 13
commented Nov 29, 2021 by saidai (1,340 points)
Si molti hanno risolto usando il file in inglese, prova a copiare tutto e vedi se funge.
g
giac (2790 points)
7 14 27
commented Nov 29, 2021 by giac (2,790 points)
confermo, anche io ho risolto cosi
.
.Alex. (890 points)
0 0 8
answered Nov 29, 2021 by .Alex. (890 points)
Se vuoi direttamente individuare l'errore, devi appunto ricercare il carattere in posizione 3696 nel tuo programma (perciò dal primo carattere che usi nel codice devi scoorere fino al 3696°).
Non ne sono certo, ma il byte 0xF9 dovrebbe corrispondere una "ù", che viene letta anche come "ù" e per questo si crea l'errore.
Comunque, variando il carattere che crea il problema, dovresti risolvere.