DeprecationWarning HW

f
fraa.dap (1280 points)
4 9 15
asked Oct 28, 2021 in HW2 by fraa.dap (1,280 points)

Quando faccio il test del mio HW vengono generati 2 Warning, DeprecationWarning per la precisione. Ho installato tutte le librerie occorrenti da Anaconda come indicato qui

..\..\..\anaconda3\lib\site-packages\pyreadline\py3k_compat.py:8
  C:\Users\Account2\anaconda3\lib\site-packages\pyreadline\py3k_compat.py:8: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated since Python 3.3, and in 3.9 it will stop working
    return isinstance(x, collections.Callable)

..\..\..\anaconda3\lib\site-packages\win32\lib\pywintypes.py:2
  C:\Users\Account2\anaconda3\lib\site-packages\win32\lib\pywintypes.py:2: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
    import imp, sys, os

-- Docs: https://docs.pytest.org/en/stable/warnings.html

2 Answers

B
BesMorgan (2950 points)
1 2 16
answered Oct 28, 2021 by BesMorgan (2,950 points)
Che versione di spyder hai? Avevamo un problema simile con l’HW opzionale per alcune librerie che non sono ancora state aggiornate sulla versione 5 di spyder
f
fraa.dap (1280 points)
4 9 15
commented Oct 28, 2021 by fraa.dap (1,280 points)
Ho Spyder 4.2.5 e Python 3.8
Exyss (21390 points)
1 2 79
answered Oct 28, 2021 by Exyss (21,390 points)
edited Oct 28, 2021 by Exyss

Sono "problemi" relativi ad alcuni import fatti dai test che erano disponibili in una vecchia versione di Python che non coincide con quella installata sul tuo Anaconda. Puoi o installare una versione leggermente più vecchia di Python (la 3.8 dovrebbe andar bene, è consigliata anche dal professore visto che i test sulla vm sono eseguiti su quella versione), oppure ignorare i warning, tanto non influiscono sulla riuscita dei test essendo solo un avviso di futura rimozione delle funzionalità nella prossima versione che uscirà di Python (ossia 3.10)

f
fraa.dap (1280 points)
4 9 15
commented Oct 28, 2021 by fraa.dap (1,280 points)
Io ho la versione 3.8 di Python